目录
VAGAA, EMULE AND APPLE

** VAGAA, EMULE AND APPLE:** <Excerpt in index | 首页摘要>

<The rest of contents | 余下全文>

Vagaa, eMule and Apple
Time Limit: 1000 MS Memory Limit: 65536 K
Total Submit: 105(57 users) Total Accepted: 54(50 users) Rating: Special Judge: No
Description
Vagaa is a strange dog and eMule is a strange mule. They are friends.

They love apples and math.

One day, they buy a big apple which weighs w kilos. They wonder whether they can divide it into exactly two parts in a way that each part weighs even number of kilos.

Input
There are multiple test cases. The first line of input is an integer T indicating the number of test cases. Then T test cases follow.

For each test case:

Line 1. This line contains an integer w (1 ≤ w ≤ 100).

Output
For each test case:

Line 1. Output “YES” if they can, otherwise output “NO”.

Sample Input
1

10

Sample Output
YES

Hint
In the sample, they can divide the apple into two parts of 2 and 8 kilos.

Source
哈理工2012春季校赛 - 现场赛(热身)
Author
齐达拉图@HRBUST
为毛这种题三颗星

Code
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
#include<iostream>
#include<algorithm>
#include<cmath>
using namespace std;
int main()
{
int T;
while(~scanf("%d",&T))
{
while(T--)
{
int n;
scanf("%d",&n);
int i;
int key=0;
for(i=2;i<=n/2;i+=2)
{
if((n-i)%2==0)
{
key=1;
break;
}
}
if(key==1)
{
cout<<"YES"<<endl;
}
else
{
cout<<"NO"<<endl;
}
}
}
return 0;
}
文章作者: 爱笑的k11
文章链接: http://1315402725.github.io/posts/79a83d23/
版权声明: 本博客所有文章除特别声明外,均采用 CC BY-NC-SA 4.0 许可协议。转载请注明来自 爱笑的k11
打赏
  • 微信
  • 支付寶

评论